WhatsApp
Yükleniyor....

Dikkat! Popüler Apache Log4j Java Kütüphanesinde Sıfırıncı Gün Güvenlik Açığı

Yazılarımız ve Makalelerimiz.

15 Aralık 2021, 13:18 0 Yorum 629 Okuma

Log4j Nedir ?

Log4j, Ceki GÜLCÜ tarafından geliştirilmeye başlanıp devamında Apache Software Foundation’a devredilmiş ve Apache Software Foundation tarafından geliştirilen ve sürdürülen java tabanlı bir loglama kütüphanesidir. Kütüphane, Java için günlük kaydı çerçevesi olarak birçok ticari ve açık kaynaklı yazılım ürününde yaygın olarak benimsenir ve kullanılır.

Kritik Sıfırıncı Gün Log4J Güvenlik Açığı

Apache Software Foundation, yaygın olarak kullanılan Apache Log4j Java kütüphanesini etkileyen ve aktif olarak yararlanılan sıfırıncı gün güvenlik açığı tespit edildi ve bu açığı içeren düzeltmeler yayınladı. CVE-2021-44228 olarak izlenen güvenlik açığı (RCE) sistemde kötü amaçlı kod yürütmek ve savunmasız sistemlerin tamamen ele geçirilmesine neden olmaktadır.

Güvenlik açığı, CVSS derecelendirme sisteminde sorunun ciddiyetinin göstergesi olarak 10 üzerinden 10 mükemmel bir puan aldı.

Log4j; Amazon, Apple iCloud, Cisco , Cloudflare , ElasticSearch, Red Hat , Steam, Tesla, Twitter ve Minecraft gibi video oyunları dahil olmak üzere bir dizi üretici tarafından çeşitli popüler yazılımlarda bir log paketi olarak kullanılmaktadır.

Log4j'nin kurumsal BT ve DevOps'ta kullanım kolaylığı ve yaygınlığı göz önüne alındığında, hassas sunuculara yönelik kritik saldırıların önümüzdeki günlerde artması ve bu kusurun derhal ele alınmasını zorunlu hale getirmesi bekleniyor. İsrailli siber güvenlik firması Cybereason ayrıca, loglayıcıyı yeniden yapılandırmak ve saldırının daha fazla istismar edilmesini önlemek için güvenlik açığının kendisini kullanarak eksikliği kapatan "Logout4Shell" adlı bir düzeltme yayınladı.

Log4J Güvenlik Açığından Etkilenen Ürünler

Log4J 2.0-beta9 ile 2.14.1 (dahil) arasındaki sürümler bu güvenlik açığından etkilenmektedir. Ayrıca etkilenen ürünler aşağıdaki gibidir.

-Java tabanlı birçok uygulama
-Apache
-ElasticSearch
-Flume
-Kafka
-VMWare
-NetApp
-Etkilenen tüm ürünlere buradan ulaşabilirsiniz.

Nasıl Tespit Edilir ?

Hangi sistemlerde Log4j kullanıldığını ve güvenlik açığını barındırma kontrolünü aşağıda ki gibi tespit edebilirsiniz.  

Linux sistemler için:

Komut satırına “grep -r ‘org/apache/logging/log4/corelookup/JndiLookup.class’/” komutu yazılır, çıktı olarak “binary file matches”

Windows sistemler için:

Windows sistemler için Github deposundan ilgili komutlar çalıştırılabilir.

Nasıl Korunulur ?

-Kütüphane Apache Log4j 2.15.0 sürümüne yükseltilmelidir.
-İnternete yönelik yazılımlar / cihazlar için ilgili güvenlik yamalarını hızlıca uygulanmalıdır.
-Herhangi bir nedenle yama mümkün değilse, sistemi İnternet'ten ayırmanızı ve/veya aşağıdaki etki azaltma önlemlerini uygulamanızı şiddetle tavsiye edilmektedir.
-Güvenlik açığı olan sistemleriniz varsa herhangi bir kötüye kullanım belirtisi olup olmadığını çok dikkatli bir şekilde kontrol edilmelidir.
-WAF, SIEM, Loglama ürünlerinin kullanılması durumunda, log4j'ye özgü kurallar uygulanmalıdır.

Detaylı ve Faydalı Kaynaklar:

Kaynak1

Kaynak2

Kaynak3

Okuyucu Yorumları

0 Yorum